iZotope Plugin issues with Cubase 9.5 in Windows


#1

I ran into the following issues after upgrading to Cubase 9/9.5 where iZotope plugins either are blacklisted or not loading - so I did some research and found the following:


–> 64-bit processing precision can increase the CPU load and memory consumption!

Please keep in mind:

  • Double precision processing is not available for VST2 plug-ins!

  • Whether a VST3 plug-in or instrument supports 64-bit processing precision is up to the manufacturer of the plug-ins. Some manufacturers advertise an internal (!) 64-bit processing for their plug-ins but still do not support a complete audio processing in 64-bit double precision throughout the whole signal path.

64 bit is not the same as 64 bit floating:

https://www.izotope.com/en/support/knowledge-base/differences-between-32-bit-and-64-bit-audio-software-plug-ins.html

If anyone has a tested and recommended plugin which allows us to run iZotope plugins with no issues please let me know. I’m tired of reinstalling iZotope again and again with it not working properly.


#2

Have you tried jBridge? I haven’t needed it as my Cubase 9.5 seems happy with iZotope, but I hear it is good for this stuff…


#3

I have heard about jBride and have used it in the past. I wasn’t sure if anyone else had issues with PC based Cubase 9.5 and izotope plugins.


#4

Elton, do you have Mac or PC?


#5

PC. I just don’t get the mac thing. Unless you want Logic? Or to run on a laptop maybe? The PC I have is an absolute beast in terms of amount of SSD drives, CPU, etc. And for less than an average Mac. I love my iPad, iPhone etc. But with the same budget spent on PC or Mac there is no comparison. I know it’s a debate that rages on, but there you have it. I’m on the PC side of that fence!


#6

Hi Elton, I think I figured it out. I had to update Windows Updates and NVDIA drivers and it started working :slight_smile: I found some write up about it online that it can be related to video drivers. I had a great weekend mixing my song.